Lower required TLS version on the Remote Worker OVA

Pliant workers by default require that the systems they connect to via TLS support a minimum TLS version of 1.2, as versions less than that are considered vulnerable. However, sometimes customers need to have Pliant interact with legacy systems that may not yet have TLS1.2 support. In this case, the on premise remote worker can be reconfigured to allow connections using older TLS versions.

This change will be undone if you use the rwconfig command in the future

  1. Sign in to the Remote Worker OVA using the “plconfig” user and the password you set on the appliance

  2. Enter the command “bash” at the menu prompt. You will need to re-enter your password. This will open a command prompt

  3. Enter the command “vi pliant-worker/worker-config.env” to edit with worker configuration file

  4. Press the Shift key and then the letter O, this should create a new blank line at the top of the file

  5. In the new line, enter: “NODE_OPTIONS=--tls-min-v1.1”
    (You can use “NODE_OPTIONS=--tls-min-v1.0” as well if desired)

  6. Press the escape key, then enter “:wq” and press enter. This will exit editing, safe the file, and quit the editor.

  7. Enter the “rwrestart” command to restart the remote worker containers and make the change effective